PisoWiFi Voucher Purchase via EWallets

Documentation version 1.0


Introduction


First of all, Thank you so much for giving an interest to this project. You are awesome!
This documentation will enable your vendo portal to have a feature wherein your customer can purchase internet voucher codes via EWallets (GCash, Maya, Grab, ShopeePay and more).

Fees

As much as I want it give this for free, keeping this project running have expenses (e.g Server Maintenance, SSLs certificate, domains, Payment Gateway solutions, VPN etc.). With this in mind, we would need to collect small fees. Below are the details.
  1. 250PhP registration fee
  2. 5% for every successful voucher purchase. Example: If your use purchase a 100pesos voucher via EWallet, you will be creadited 95php on your gcash account
  3. 12PhP Fix Transfer fee from our account to your GCash account
The payments will be automatically transferred to you once you reached the minimum disbursement amount of 500PhP.

How it works

I created a video demonstration for both Juanfi and Adopisoft vendo system which you can find below.

Getting Started

You will need to do the following.

  1. Purchase VPN account via telegram
  2. Run Mikrotik scripts to your terminal
  3. Assign Nodemcu to create voucher code when your customer purchase it via EWallets

A bit overwhelming? I gotchu fam!

JUANFI SYSTEM - Purchase VPN via Telegram

Note: Make sure that you already registered and downloaded Telegram on your Mobile Phone or PC


Step 1: Finding the telegram bot.

Open Telegram app, then search for the bot wifree-voucher-ewallet-portal, then click start
Note: This will be the same process on Mobile phone.

You should receive a message response just like this:

Hi,

Welcome to Voucher Purchase Self-service hub.
This bot will help you to install voucher purchase portal
using EWallets (Gcash, Paymaya, Shopeepay, etc.)
on your Vendo System. The registration fee is 250PhP

Currently, we're supporting the following System
- JuanFi
- Adopisoft

Please type /register command to get you started.
                                    


Step 2: Generate Checkout link

You will need to create a checkout link for portal key and VPN account by typing below format, then SEND.

/register [SPACE] YourGCashNumber [SPACE] juanfi

For example:
/register 09669041361 juanfi
                                    
Note: Make sure that you will add a valid GCash number when generating the checkout link. The submitted GCash number will be used as a receiver for disbursement. A checkout link should be generated after submitting the command above.


Step 3: Proceed with Payment

You will be redirected to checkout page once you click the generated checkout link. You may select any EWallet or Bank to proceed with the purchase, just follow to on-screen instruction after selecting the preferred channel.

Note: Make sure that you added a valid GCash number on Step 2 when generating the checkout link. The submitted GCash number will be used as a receiver for disbursement. A checkout link should be generated after submitting the command above.

You should receive the same message below when your purchase is successful.
We've received your payment and now processing your voucher portal key. We would request for your patience during this time. Here's your payment ref#: REGISTEREWALLETPORTAL-0966xxx-juanfi-xxx-xxx.


Step 4: WAIT!

Yup, we need you to wait.

System is now processing your VPN account. It would just take at least more or less than 5 minutes. After this, you should receive another the same message below:

Thank you for your patience. Here's your account details:
Portal Key: SAMPLE123
SSTP Username: SAMPLE12345
SSTP Password: SAMPLE123456

Congratulations! You've successfully purchased a VPN account and now ready to install the plugin

Installing Plugin to JuanFi

Be sure that you are done purchasing VPN account first before proceeding on this step.


Step 1: Adding SSTP Client account

Open your Mikrotik via Winbox
  1. Navigate to Interface
  2. Click the + button
  3. Click SSTP Client
on Dial out tab, input the following credentials
  • - Connect To: vpn.wifree.network
  • - Port: 444
  • - User: Your SSTP username
  • - Password: Your SSTP Password
After encoding the credentials, click Apply button.

Step 2: Check the SSTP Client Status

Once done with Step 1, navigate to Status Tab
  1. You should see Enable on lower right
  2. Also indicated that SSTP client is running
  3. The status is Connected
  4. Local and Remote IP should have values populated

Step 3: Add entries on Walled Garden IP List

You just need to copy the code below, then paste it on your Mikrotik Terminal
/ip firewall address-list
add address=gcash.com list=reminder-allow-site
add address=assets.xendit.co list=reminder-allow-site
add address=checkout-ui-gateway.xendit.co list=reminder-allow-site
add address=payments.gcash.com list=reminder-allow-site
add address=xendit.co list=reminder-allow-site
add address=maya.ph list=reminder-allow-site
add address=pg-sandbox.paymaya.com list=reminder-allow-site
add address=api.paymaya.com list=reminder-allow-site
add address=ewallet-service-live.xendit.co list=reminder-allow-site
add address=wifree.network list=reminder-allow-site
add address=gw.alipayobjects.com list=reminder-allow-site
add address=irisk-sea.alipay.com list=reminder-allow-site
add address=grabpay-connector-live.xendit.co list=reminder-allow-site
add address=weblogin.grab.com list=reminder-allow-site
add address=partner-api.grab.com list=reminder-allow-site
add address=grab.com list=reminder-allow-site
add address=pay.grab.com list=reminder-allow-site
add address=app.appsflyer.com list=reminder-allow-site
add address=shopee.ph list=reminder-allow-site
add address=wsa.wallet.airpay.com.ph list=reminder-allow-site
add address=connect.paymaya.com list=reminder-allow-site
add address=digicert.com list=reminder-allow-site
add address=checkout.xendit.co list=reminder-allow-site
add address=mynt.xyz list=reminder-allow-site
add address=mgs-gw.paas.mynt.xyz list=reminder-allow-site
add address=traefik-public.ap-southeast-1.tidnex.com list=reminder-allow-site
add address=paas.mynt.xyz list=reminder-allow-site
add address=www.recaptcha.com list=reminder-allow-site
add address=js.xendit.co list=reminder-allow-site
add address=xnd-merchant-logos.s3.amazonaws.com list=reminder-allow-site
add address=cloudfront.net list=reminder-allow-site
add address=snowflow-collector.iluma.ai list=reminder-allow-site
add address=beacons.gvt2.com list=reminder-allow-site
add address=beacons.gcp.gvt2.com list=reminder-allow-site
add address=discover-pa.googleapis.com list=reminder-allow-site
add address=fonts.googleapis.com list=reminder-allow-site
add address=www.googletagmanager.com list=reminder-allow-site
add address=content-autofill.googleapis.com list=reminder-allow-site
add address=payments.wifree.network list=reminder-allow-site
add address=challenges.cloudflare.com list=reminder-allow-site
add address=cnd.growthbook.io list=reminder-allow-site
add address=iluma.ai list=reminder-allow-site
add address=datadoghq-browser-agent.com list=reminder-allow-site
add address=cdn.jsdelivr.net list=reminder-allow-site
add address=client4.google.com list=reminder-allow-site
add address=www.gstatic.com list=reminder-allow-site
add address=snowplow-collector.iluma.ai list=reminder-allow-site
add address=cdn.growthbook.io list=reminder-allow-site
add address=gcash-api.pulseid.com list=reminder-allow-site
add address=mss.paas.mynt.xyz list=reminder-allow-site
add address=api.mynt.xyz list=reminder-allow-site
add address=login.mynt.xyz list=reminder-allow-site
add address=customer-segment-api.mynt.xyz list=reminder-allow-site
add address=mdap.paas.mynt.xyz list=reminder-allow-site
add address=cdnjs.cloudflare.com list=reminder-allow-site
add address=xqd9eal.x.incapdns.net list=reminder-allow-site
add address=rum-ingest.us1.signalfx.com list=reminder-allow-site
add address=110.75.232.97 list=reminder-allow-site
add address=110.75.232.98 list=reminder-allow-site
add address=110.75.232.99 list=reminder-allow-site
add address=110.75.232.100 list=reminder-allow-site
add address=xen.to list=reminder-allow-site
add address=18.138.78.193 list=reminder-allow-site
add address=3.0.107.195 list=reminder-allow-site
add address=3.1.78.74 list=reminder-allow-site
add address=e9816.cj.akamaiedge.net list=reminder-allow-site
add address=104.67.185.229 list=reminder-allow-site
add address="ab448ad13c5be11eab89b06680ff93a5-46768361.ap-southeast-1.elb.amazonaws.com" list=reminder-allow-site
add address=stats.g.doubleclick.net list=reminder-allow-site
add address=www.google-analytics.com list=reminder-allow-site
add address=cloudflareinsights.com list=reminder-allow-site
add address=d39ewjhej4wmka.cloudfront.net list=reminder-allow-site
add address=cdnj.cloudflare.com list=reminder-allow-site
/ip hotspot walled-garden ip
add action=accept disabled=no !dst-address dst-address-list=reminder-allow-site !dst-port !protocol !src-address !src-address-list comment="ALLOW LIST FOR ECASH PAYMENT"
/ip hotspot walled-garden ip
                                

Step 4: Getting your JuanFi API Key

We will need to assign 1 Juanfi Nodemcu to create a voucher when your customer bought voucher code via EWallet. With this, we will need the JuanFi API Key. In order to find it, you will need to open your JuanFi Admin page
  1. Open the JuanFi admin page via http://NodemcuIPAddress/login.
    For example: http://10.0.0.74/login
  2. Login with your Juanfi username and password. You should now this :)
  3. Navigate to System Configuration, then API Key
  4. Take note of the Nodemcu IP Address and API Key
  5. Proceed to Step 5
Note: It is my recommendation to create a dedicated/separate juanfi nodemcu that will be assigned for this purpose. You just need to flash a new nodemcu, then bind it to your mikrotik.

Step 5: Binding your JuanFi API Key

Open Telegram app, then search for the bot wifree-voucher-ewallet-portal, and type the following command:
/juanfi [SPACE] YOUR-PORTAL-KEY [SPACE] YOUR-PAYMENT-REFERENCE# [SPACE] YOUR-JUANFI-API-KEY

For example:
/juanfi 65a368a16332f REGISTEREWALLETPORTAL-09669041361-juanfi-65a368a16332f-801107489 test123

Wherein,
65a368a16332f -->> the portal key created on Purchase VPN via telegram Step 3
REGISTEREWALLETPORTAL-09669041361-juanfi-65a368a16332f-801107489 -->> the payment ref# created on Purchase VPN via telegram Step 3
test123 -->> The API Key that you taken note from How to install plugin to JuanFi Step 4
                                
After submitting the command, you should receive a You've successfully updated your Juanfi API key response.

Step 6.5:


Step 6.6:


Sample of what it looks like when dragging the NAT entry to top most.

Step 6: Port forward SSTP to Nodemcu IP Address

We will need to port forward the SSTP local IP Address to your Nodemcu IP address (From Step 4). To do this,
  1. Open your Mikrotik WinBox
  2. Navigate to IP, then Firewall
  3. Proceed to NAT tab
  4. Click + button
  5. Add the following on General Tab:
    - Chain: dstnat
    - Dst. Address: SSTP Local address --> You can get this on Step 2
    - Protocol: 6 (tcp)
    - Dst Port: 80
  6. Add the following on Action Tab:
    - Action: dst-nat
    - To Addresses: Nodemcu IP Address --> You can get this on Step 4
    - To Ports: 80
  7. Click Ok button
Once NAT has been added, make sure to move the entry to the top most by dragging it (please see screenshot for reference).

Step 7: Adding a widget to your hotspot template

We're almost done! Now, we will need to add a widget button to your hotspot template.
TAKE NOTE: You will need to identify how your hotspot template were build. In my experience, there are two types:

template#1 - you will need to open and check your login.html and status.html. If the said file contains long HTML codes, then it is template#1

template#2 - check login.html and status.html. If the said file contains redirect code, then it is template#2. One example is the said file only contains

location.replace('/portal.html');
                                    
Where the portal.html is your main file. Take note that other hotspot template have different .html name

For template#1 - Open status.html and login.html using notepad or note++ (recommended)
For template#2 - Open the redirect file. E.g portal.html (this is just a sample in my case)
then find the /body tag (This usually at the end of the file). Add the code below:
    
	


                                
Replace the src value with your portal key. For example:
https://payments.wifree.network/widget/voucher/juanfi/index.html?portal_key=[YOUR-PORTAL-KEY]
The portal key is provided on Purchase VPN via telegram Step 3. Here's an example for your reference:

Step 8: Check if the widget has been successfully added

Once you followed all the steps, you should be able to see a widget on your hotspot portal. Congratulations! Your customer may now purchase voucher code using Ewallets like GCash and PayMaya.

You may test the payment widget on yourself if its working. Below are the sample for your reference.

ADOPISOFT SYSTEM - Purchase Portal Key via Telegram

Note: Make sure that you already registered and downloaded Telegram on your Mobile Phone or PC


Step 1: Finding the telegram bot.

Open Telegram app, then search for the bot wifree-voucher-ewallet-portal, then click start
Note: This will be the same process on Mobile phone.

You should receive a message response just like this:

Hi,

Welcome to Voucher Purchase Self-service hub.
This bot will help you to install voucher purchase portal using EWallets (Gcash, Paymaya, Shopeepay, etc.)
on your Vendo System. Please see registration fee below:

Vendo System:
- JuanFi --> 250PhP
- Adopisoft --> 100PhP

Please type /register command to get you started.
                                    


Step 2: Generate Checkout link

You will need to create a checkout link for portal key and VPN account by typing below format, then SEND.

/register [SPACE] YourGCashNumber [SPACE] ado

For example:
/register 09669041361 ado
                                    
Note: Make sure that you will add a valid GCash number when generating the checkout link. The submitted GCash number will be used as a receiver for disbursement. A checkout link should be generated after submitting the command above.


Step 3: Proceed with Payment

You will be redirected to checkout page once you click the generated checkout link. You may select any EWallet or Bank to proceed with the purchase, just follow to on-screen instruction after selecting the preferred channel.

Note: Make sure that you added a valid GCash number on Step 2 when generating the checkout link. The submitted GCash number will be used as a receiver for disbursement. A checkout link should be generated after submitting the command above.

You should receive the same message below when your purchase is successful.
We've received your payment and now processing your voucher portal key. We would request for your patience during this time. Here's your payment ref#: REGISTEREWALLETPORTAL-0966xxx-ado-xxx-xxx.


Step 4: WAIT!

Yup, we need you to wait.

System is now processing your VPN account. It would just take at least more or less than 5 minutes. After this, you should receive another the same message below:

Thank you for your patience. Here's your account details:
Portal Key: ******

Congratulations! You've successfully purchased a Portal account and now ready to install the plugin for Adopisoft System

Installing Plugin to JuanFi

Be sure that you are done purchasing VPN account first before proceeding on this step.


Step 1: Adding SSTP Client account

Open your Mikrotik via Winbox
  1. Navigate to Interface
  2. Click the + button
  3. Click SSTP Client
on Dial out tab, input the following credentials
  • - Connect To: vpn.wifree.network
  • - Port: 444
  • - User: Your SSTP username
  • - Password: Your SSTP Password
After encoding the credentials, click Apply button.

Step 2: Check the SSTP Client Status

Once done with Step 1, navigate to Status Tab
  1. You should see Enable on lower right
  2. Also indicated that SSTP client is running
  3. The status is Connected
  4. Local and Remote IP should have values populated

Step 3: Add entries on Walled Garden IP List

You just need to copy the code below, then paste it on your Mikrotik Terminal
/ip hotspot walled-garden ip
add action=accept disabled=no !dst-address !dst-address-list dst-host=\
    *.xendit.co !dst-port !protocol !src-address !src-address-list
add action=accept disabled=no !dst-address !dst-address-list dst-host=\
    checkout.xendit.co !dst-port !protocol !src-address !src-address-list
add action=accept disabled=no !dst-address !dst-address-list dst-host=\
    payments.maya.ph !dst-port !protocol !src-address !src-address-list
add action=accept disabled=no !dst-address !dst-address-list dst-host=maya.ph \
    !dst-port !protocol !src-address !src-address-list
add action=accept disabled=no !dst-address !dst-address-list dst-host=\
    assets.paymaya.com !dst-port !protocol !src-address !src-address-list
add action=accept disabled=no !dst-address !dst-address-list dst-host=\
    paymaya.com !dst-port !protocol !src-address !src-address-list
add action=accept disabled=no !dst-address !dst-address-list dst-host=\
    api.paymaya.com !dst-port !protocol !src-address !src-address-list
add action=accept disabled=no !dst-address !dst-address-list dst-host=\
    pg-sandbox.paymaya.com !dst-port !protocol !src-address !src-address-list
add action=accept disabled=no !dst-address !dst-address-list dst-host=\
    connect.paymaya.com !dst-port !protocol !src-address !src-address-list
add action=accept disabled=no !dst-address !dst-address-list dst-host=\
    wsa.wallet.airpay.com.ph !dst-port !protocol !src-address \
    !src-address-list
add action=accept disabled=no !dst-address !dst-address-list dst-host=\
    shopee.ph !dst-port !protocol !src-address !src-address-list
add action=accept disabled=no !dst-address !dst-address-list dst-host=\
    app.appsflyer.com !dst-port !protocol !src-address !src-address-list
add action=accept disabled=no !dst-address !dst-address-list dst-host=\
    pay.grab.com !dst-port !protocol !src-address !src-address-list
add action=accept disabled=no !dst-address !dst-address-list dst-host=\
    grab.com !dst-port !protocol !src-address !src-address-list
add action=accept disabled=no !dst-address !dst-address-list dst-host=\
    partner-api.grab.com !dst-port !protocol !src-address !src-address-list
add action=accept disabled=no !dst-address !dst-address-list dst-host=\
    weblogin.grab.com !dst-port !protocol !src-address !src-address-list
add action=accept disabled=no !dst-address !dst-address-list dst-host=\
    grabpay-connector-live.xendit.co !dst-port !protocol !src-address \
    !src-address-list
add action=accept disabled=no !dst-address !dst-address-list dst-host=\
    gcash.com !dst-port !protocol !src-address !src-address-list
add action=accept disabled=no !dst-address !dst-address-list dst-host=\
    payments.gcash.com !dst-port !protocol !src-address !src-address-list
add action=accept disabled=no !dst-address !dst-address-list dst-host=\
    irisk-sea.alipay.com !dst-port !protocol !src-address !src-address-list
add action=accept disabled=no !dst-address !dst-address-list dst-host=\
    gw.alipayobjects.com !dst-port !protocol !src-address !src-address-list
add action=accept disabled=no !dst-address !dst-address-list dst-host=\
    payments.wifree.network !dst-port !protocol !src-address \
    !src-address-list
add action=accept disabled=no !dst-address !dst-address-list dst-host=\
    ewallet-service-live.xendit.co !dst-port !protocol !src-address \
    !src-address-list
add action=accept disabled=no !dst-address !dst-address-list dst-host=\
    mynt.xyz !dst-port !protocol !src-address !src-address-list
add action=accept disabled=no !dst-address !dst-address-list dst-host=\
    mgs-gw.paas.mynt.xyz !dst-port !protocol !src-address !src-address-list
add action=accept disabled=no !dst-address !dst-address-list dst-host=\
    payments-web-assets.maya.ph !dst-port !protocol !src-address \
    !src-address-list
add action=accept disabled=no !dst-address !dst-address-list dst-host=\
    traefik-public.ap-southeast-1.tidnex.com !dst-port !protocol !src-address \
    !src-address-list
add action=accept disabled=no !dst-address !dst-address-list dst-host=assets.xendit.co !dst-port !protocol !src-address !src-address-list
add action=accept disabled=no !dst-address !dst-address-list dst-host=checkout-ui-gateway.xendit.co !dst-port !protocol !src-address !src-address-list


                                

Step 4: Getting your JuanFi API Key

We will need to assign 1 Juanfi Nodemcu to create a voucher when your customer bought voucher code via EWallet. With this, we will need the JuanFi API Key. In order to find it, you will need to open your JuanFi Admin page
  1. Open the JuanFi admin page via http://NodemcuIPAddress/login.
    For example: http://10.0.0.74/login
  2. Login with your Juanfi username and password. You should now this :)
  3. Navigate to System Configuration, then API Key
  4. Take note of the Nodemcu IP Address and API Key
  5. Proceed to Step 5
Note: It is my recommendation to create a dedicated/separate juanfi nodemcu that will be assigned for this purpose. You just need to flash a new nodemcu, then bind it to your mikrotik.

Step 5: Binding your JuanFi API Key

Open Telegram app, then search for the bot wifree-voucher-ewallet-portal, and type the following command:
/juanfi [SPACE] YOUR-PORTAL-KEY [SPACE] YOUR-PAYMENT-REFERENCE# [SPACE] YOUR-JUANFI-API-KEY

For example:
/juanfi 65a368a16332f REGISTEREWALLETPORTAL-09669041361-juanfi-65a368a16332f-801107489 test123

Wherein,
65a368a16332f -->> the portal key created on Purchase VPN via telegram Step 3
REGISTEREWALLETPORTAL-09669041361-juanfi-65a368a16332f-801107489 -->> the payment ref# created on Purchase VPN via telegram Step 3
test123 -->> The API Key that you taken note from How to install plugin to JuanFi Step 4
                                
After submitting the command, you should receive a You've successfully updated your Juanfi API key response.

Step 6.5:


Step 6.6:


Sample of what it looks like when dragging the NAT entry to top most.

Step 6: Port forward SSTP to Nodemcu IP Address

We will need to port forward the SSTP local IP Address to your Nodemcu IP address (From Step 4). To do this,
  1. Open your Mikrotik WinBox
  2. Navigate to IP, then Firewall
  3. Proceed to NAT tab
  4. Click + button
  5. Add the following on General Tab:
    - Chain: dstnat
    - Dst. Address: SSTP Local address --> You can get this on Step 2
    - Protocol: 6 (tcp)
  6. Add the following on Action Tab:
    - Action: dst-nat
    - To Addresses: Nodemcu IP Address --> You can get this on Step 4
    - To Ports: 80
  7. Click Ok button
Once NAT has been added, make sure to move the entry to the top most by dragging it (please see screenshot for reference).

Step 7: Adding a widget to your hotspot template

We're almost done! Now, we will need to add a widget button to your hotspot template.
TAKE NOTE: You will need to identify how your hotspot template were build. In my experience, there are two types:

template#1 - you will need to open and check your login.html and status.html. If the said file contains long HTML codes, then it is template#1

template#2 - check login.html and status.html. If the said file contains redirect code, then it is template#2. One example is the said file only contains

location.replace('/portal.html');
                                    
Where the portal.html is your main file. Take note that other hotspot template have different .html name

For template#1 - Open status.html and login.html using notepad or note++ (recommended)
For template#2 - Open the redirect file. E.g portal.html (this is just a sample in my case)
then find the /body tag (This usually at the end of the file). Add the code below:
    
	


                                
Replace the src value with your portal key. For example:
https://payments.wifree.network/widget/voucher/juanfi/index.html?portal_key=[YOUR-PORTAL-KEY]
The portal key is provided on Purchase VPN via telegram Step 3. Here's an example for your reference:

Step 8: Check if the widget has been successfully added

Once you followed all the steps, you should be able to see a widget on your hotspot portal. Congratulations! Your customer may now purchase voucher code using Ewallets like GCash and PayMaya.

You may test the payment widget on yourself if its working. Below are the sample for your reference.

Optional: Receive Telegram notification

Doing this step will enable you to receive a telegram notification of the following:
  1. When your customer purchased voucher code via EWallet
  2. When our system will disbursement payments to your GCash Account

Open Telegram app, then search for the bot wifree_alert_bot, then click start
Note: This will be the same process on Mobile phone.

You should receive a message response just like this:

Hi,

Thank you for availing PPPoE/Hotspot GCASH payment.
Here's your ChatID: 801107489
                                    
Take note of the ChatID.

Head back to wifree-voucher-ewallet-portal bot, then send the command format below:

/telegram [SPACE] YOUR-PORTAL-KEY [SPACE] YOUR-PAYMENT-REFERENCE# [SPACE] YOUR-ChatID

For example:
/telegram 65a368a16332f REGISTEREWALLETPORTAL-09669041361-juanfi-65a368a16332f-801107489 801107489

Wherein,
65a368a16332f -->> the portal key created on Purchase VPN via telegram Step 3
REGISTEREWALLETPORTAL-09669041361-juanfi-65a368a16332f-801107489 -->> the payment ref# created on Purchase VPN via telegram Step 3
801107489 -->> The ChatID
                                
After submitting the command, you should receive a You've successfully updated your telegram notification settings.

ADOPISOFT SYSTEM - Purchase Portal Key via Telegram

Note: Make sure that you already registered and downloaded Telegram on your Mobile Phone or PC


Step 1: Finding the telegram bot.

Open Telegram app, then search for the bot wifree-voucher-ewallet-portal, then click start
Note: This will be the same process on Mobile phone.

You should receive a message response just like this:

Hi,

Welcome to Voucher Purchase Self-service hub.
This bot will help you to install voucher purchase portal using EWallets (Gcash, Paymaya, Shopeepay, etc.)
on your Vendo System. Please see registration fee below:

Vendo System:
- JuanFi --> 250PhP
- Adopisoft --> 100PhP

Please type /register command to get you started.
                                    


Step 2: Generate Checkout link

You will need to create a checkout link for portal key and VPN account by typing below format, then SEND.

/register [SPACE] YourGCashNumber [SPACE] ado

For example:
/register 09669041361 ado
                                    
Note: Make sure that you will add a valid GCash number when generating the checkout link. The submitted GCash number will be used as a receiver for disbursement. A checkout link should be generated after submitting the command above.


Step 3: Proceed with Payment

You will be redirected to checkout page once you click the generated checkout link. You may select any EWallet or Bank to proceed with the purchase, just follow to on-screen instruction after selecting the preferred channel.

Note: Make sure that you added a valid GCash number on Step 2 when generating the checkout link. The submitted GCash number will be used as a receiver for disbursement. A checkout link should be generated after submitting the command above.

You should receive the same message below when your purchase is successful.
We've received your payment and now processing your voucher portal key. We would request for your patience during this time. Here's your payment ref#: REGISTEREWALLETPORTAL-0966xxx-ado-xxx-xxx.


Step 4: WAIT!

Yup, we need you to wait.

System is now processing your VPN account. It would just take at least more or less than 5 minutes. After this, you should receive another the same message below:

Thank you for your patience. Here's your account details:
Portal Key: ******

Congratulations! You've successfully purchased a Portal account and now ready to install the plugin for Adopisoft System

Installing plugin to Adopisoft (Coming Soon!)

Step 1: Adding Domain to Allowed host (walled-garden).

Login to your Adopisoft portal (Default is 10.0.0.1/login), then do the following:

  1. On Upper right of the screen, type Add Allowed Host on search bar
  2. Click Add Allowed Host on the suggestion menu.
  3. Add the following domains:
    xendit.co
    maya.ph
    pg-sandbox.paymaya.com
    api.paymaya.com
    ewallet-service-live.xendit.co
    gw.alipayobjects.com
    irisk-sea.alipay.com
    gcash.com
    payments.gcash.com
    grabpay-connector-live.xendit.co
    weblogin.grab.com
    partner-api.grab.com
    grab.com
    pay.grab.com
    app.appsflyer.com
    shopee.ph
    wsa.wallet.airpay.com.ph
    connect.paymaya.com
    www.xendit.co
    www.digicert.com
    digicert.com
    checkout.xendit.co
    mynt.xyz
    mgs-gw.paas.mynt.xyz
    payments-web-assets.maya.ph
    traefik-public.ap-southeast-1.tidnex.com
    paas.mynt.xyz
    xqd9eal.x.incapdns.net
    assets.xendit.co
    checkout-ui-gateway.xendit.co
    api.xendit.co
    b4a20ab744b5.sn.mynetname.net
    cdnj.cloudflare.com
    d39ewjhej4wmka.cloudfront.net
    cloudflareinsights.com
    www.google-analytics.com
    xendit.co
    stats.g.doubleclick.net
    ab448ad13c5be11eab89b06680ff93a5-46768361.ap-southeast-1.elb.amazonaws.com
    e9816.cj.akamaiedge.net
    xen.to
                                                


Step 2: Install Dataplicity Plugin

You may follow the video tutorial provided by Adopisoft itself below:

Once done, you should be able to retrieve your Wormhole link. Please see sample screenshot below:


Step 3: Submitting your credentials to System

Open Telegram app, then search for the bot wifree-voucher-ewallet-portal, and type the following command:
/ado [SPACE] YOUR-PORTAL-KEY [SPACE] YOUR-PAYMENT-REFERENCE# [SPACE] Wormhole|ADOusername|ADOpassword

For example:
/ado 65a368a16332f REGISTEREWALLETPORTAL-09669041361-ado-65b134441df0f-801107489 https://unriven-caterpillar-4485.dataplicity.io|admin|admin123

Wherein,
65a368a16332f -->> the portal key created on Purchase VPN via telegram Step 3
REGISTEREWALLETPORTAL-09669041361-ado-65b134441df0f-801107489 -->> the payment ref# created
https://unriven-caterpillar-4485.dataplicity.io|admin|admin123 -->> Wormhole link|Ado username| Ado Password

Once done, you should receive a response: You've successfully updated your Adopisoft information. Please see sample screenshot below:


Step 4: Adding the widget

Open your Adopisoft Admin page, then do the following
  1. Navigate to Captive Portal
  2. ClickCode Editor tab
  3. Under Edit File: index.html, paste the code below the body tag Note: Replace the src value with your portal key. For example: https://payments.wifree.network/widget/voucher/ado/index.html?portal_key=[YOUR-PORTAL-KEY]
    
	
                                

Please see sample screenshot below:


Step 5: Check if the widget has been successfully added

Once you followed all the steps, you should be able to see a widget on your Adopisoft Portal. Congratulations! Your customer may now purchase voucher code using Ewallets like GCash and PayMaya.

You may test the payment widget on yourself if its working. Below are the sample for your reference.

Receive Telegram notification

Doing this step will enable you to receive a telegram notification of the following:
  1. When your customer purchased voucher code via EWallet
  2. When our system will disbursement payments to your GCash Account

Open Telegram app, then search for the bot wifree_alert_bot, then click start
Note: This will be the same process on Mobile phone.

You should receive a message response just like this:

Hi,

Thank you for availing PPPoE/Hotspot GCASH payment.
Here's your ChatID: 801107489
                                    
Take note of the ChatID.

Head back to wifree-voucher-ewallet-portal bot, then send the command format below:

/telegram [SPACE] YOUR-PORTAL-KEY [SPACE] YOUR-PAYMENT-REFERENCE# [SPACE] YOUR-ChatID

For example:
/telegram 65a368a16332f REGISTEREWALLETPORTAL-09669041361-juanfi-65a368a16332f-801107489 801107489

Wherein,
65a368a16332f -->> the portal key created on Purchase VPN via telegram Step 3
REGISTEREWALLETPORTAL-09669041361-juanfi-65a368a16332f-801107489 -->> the payment ref# created on Purchase VPN via telegram Step 3
801107489 -->> The ChatID
                                
After submitting the command, you should receive a You've successfully updated your telegram notification settings.